Printer is detected as offline while it is online
Symptoms
When Print&Share is started, one or multiple printer channels have a red background and show that the printer is offline while the printer is actually online and fully functional.
Cause
Printer status information can be requested via two methodes or protocols: SNMP or WMI. Print&Share tries to get the printer information via SNMP as first. In some cases SNMP communication is less reliable resulting in incorrect or older printer status information.
Resolution
Solution 1:
In this step we'll disable SNMP and only request printer status information via WMI.
- Open Ricoh Print&Share
- Click [Change] in the upper-right corner to open the "Profiles" dialog.
- Click [General Configuration] in the "Profiles" dialog.
- Select the [General settings] tab in the "General Configuration".
- Change the [Available methods for detecting printer status:] to [Only WMI].
- Click [OK] and [Close] to save the setting and close the dialogs.
Solution 2:
In this step we'll change the printer channel to ignore the message that the Printer is offline.
- Open Ricoh Print&Share
- Click [Change] in the upper-right corner to open the "Profiles" dialog.
- In the "Profiles" dialog select your profile and click [Edit].
- In the "Profile" dialog select the Printer channel in the [Channels:] list.
- Click on the [Trigger points] button below the [Channels:] list.
- In the "Channel requirements" dialog select the [Print error levels] dialog.
- Find the [Offline] error and change the "Error Level" to [Warning] or [None].
- Click [OK], [OK] and [Close] to save the setting and close the dialogs.