The physical printer has changed but gives an exception in the software

Symptoms

You replace a physical printer with a different one but keep the same printer name. Possibly another brand or a different type from the same brand. You might see some exceptions in Print&Share CQ or notice incorrect output (e.g. no stapling, no duplex, wrong paper trays are being used, ...).

Cause

When you replace a physical printer with a different brand and/or type the capabilities of the printer will likely change. For example your first printer had the capabilities of printing A3, duplex and the new printer is only capable of using A4 laser (black/white). Then it's normal that previously configured settings might conflict.

Resolution

Because you keep the same printer name you need to trigger a change. Open the profile and the relevant channel. Select a different printer, save the profile. Open the profile and relevant channel again and select your printer name again. This quick & dirty method made sure that we first temporarily chose a different printer and back to the original one so that the settings were saved correctly.