An incorrect printer is being used
Symptoms
When printing to Print&Share CQ the profile uses a different printer. It is each time the same, incorrect printer that is being used.
Cause
It is possible that you renamed a printer on the Windows Server. That name change doesn't reflect inside the profile. When a channel in a profile tries to print to a printer which doesn't exist, a default one is being used. Often, not always, this is the first printer in the channel's drop-down list.
Resolution
Open the profile that is using the old name of the printer. Open the appropriate channel(s) which are using the old printer name and change the printer to the new printer name.
Repeat the steps for the other profiles that are also using the old printer name.