Cannot add domain users to allow them to print
Symptoms
When trying to add domain users in the Manage > System Setup > Security
section of Print&Share CQ you cannot find any domain users to add.
Cause
It is possible that it is related to a misconfiguration of permissions, users or network settings.
Resolution
Here are some things you could check:
- Did you install Print&Share CQ as a local user or a domain user?
- Make sure you log in on the server as a domain user
- Install Print&Share CQ with adminsitrator permissions on the domain user account.
- Check if you are on the same domain
- On the server where Print&Share CQ service is installed open PowerShell or command prompt and run the command
whoami
. - On the client pc with the user you are trying to add open PowerShell or command prompt and run the command
whoami
. - Compare both inputs and verify that the server is in the same domain as the user you are tryint to add.
- Check the user that is running the Print&Share CQ service
- Open
Services
in Windows (Services.msc
) - Locate the Print&Share CQ service (starts with
Winking
). - If you choose a different
Log On As
user, make sure this user is on the same domain as the users you are trying to add.
- Verify the connection with your domain
- On the server make sure that server is joined to a domain.
- Open PowerShell or command prompt and run the command
nltest /dsgetdc:YourDomainNameHere
to see if you can locate your Domain Controller (DC). In case you cannot find it, make sure your physical network connection is ok. Next try toping
your DC. Next check if your preferred DNS server is set correctly (ipconfig /all
) and check the SRV and A records in DNS.
- See if you can find Default Active Directory security groups
- In Print&Share CQ navigate to
Manage > System Setup > Security
. - Click Add next to Users who can print.
- Try typing
BUILTIN
and see if you have any results. - Try tying a name of a default AD security group like:
Domain Users
. If your Windows is installed in a different language, for example French, these names might be translated. Then try searching by using the tranlated (e.g. French) name of the default security group:Utilisateurs du domaine
.
A list of Default Active Directory security groups can be found here (French version)
It is possible that searching for a BUILTIN user/security group can trigger a refresh to load your AD users when you are freshly joined to a domain.