Symptoms
When going to File Processor, you are unable to select a specific printer in the Print output. The printer itself is accessible and visible in Windows Printers & Devices.
Cause
A possible cause could be that the File Processor is running under a specific user (e.g. FPUser
) but the current logged in user (e.g. User1
) who installed the printer is a different one. There is a possibility that the user FPUser
doesn't have access to the printer, because the printer is installed only for User1
and not for FPUser
.
Or the printer isn't rolled out to that specific user.
Resolution
Solution 1:
- Open Windows services (CTRL+R
services.msc
) - Stop the
Winking File Processor service
- Right mouse-click the service and select Properties and change the Log On account. Make sure you select a user that has access to the printer.
Solution 2:
Map the network drive with the user that is running the Winking File Processor service
.
Below you will find some Command Prompt or Windows Powershell commands that could help you:
See your connections:
net use
Map a network drive:
net use DRIVE: PATH
net use k: \\server\share
Map a network drive with a specific user:
net use k: \\server\share /user:Foo MyCrazyPassword
Make a mapped drive persistent (so that it stays after a PC reboot):
net use k: \\server\share /user:Foo MyCrazyPassword /persistent:Yes
You can also use the /persistent:No
switch.
To delete a mapped network drive:
net use k: /delete
Deleting all mapped network drives:
net use * /delete
See also
- Map a network drive in Windows 10 support.microsoft.com