Unable to connect to a dossier

Symptoms

You are opening the Followin´ client to work but you don't see your dossier.

Cause

Followin´ is a multi-user application, which allows clients to connect to (A) a central service. This central service connects to (B) a database to store and retrieve the data.

This article will provide some steps to verify if both the central service (A) & the database (B) are correctly configured or available.

Resolution:

A: Connecting to the central service

The central service handles and processes all requests from the clients. This service also communicates with the database.

  1. Open the Followin´ client.
  2. Navigate to Options and select Connections.
  3. Click on the OPEN DOSSIER-button.
  4. Click on the Search server-button.
    This will try to find the different Followin´ services.

In case you don't see your server, make sure that on the location that the Followin' service is installed, that you it is running.

Verify that the service is running:

  1. Open services.msc by pressing ÿ + R and typing in services.msc and click OK.
  2. Search Winking Followin' service and make sure it is running.
    If it is not running, right mouse click and select Start.

Now try to open the dossier again in Followin´, by following the steps earlier described. You should be able to select your service.

If this is not the case, try entering the Server name/IP Address and port manually.
For example:

Server: WINSRV2019QLA5
Port: 8001

In case this doesn't show you the service, try to verify the Windows Firewall is accepting communication with the service on the given port, e.g. 8001.

Image

B: Connecting to the database

The database is needed to store the dossier information. The Followin´ central service communicates with the database directly to store and retrieve information. This database can be installed on a remote server, different than the server where the central service is running.

Verify that the database is running:

  1. Log in to the server where the database (MS SQL Server) is running and open Microsoft SQL Server Management Studio (SSMS). Or connect with SSMS to a remote SQL Server.
  2. Verify that the database engine is running.
  1. In SSMS, If you right mouse click on the instance name, the Start option should be disabled because the db engine is running.
  1. Verify that the database is online.
  1. In SSMS, right mouse click on the database, choose Tasks, Bring Online should be disabled because the database is online.
  1. Verify that there is a user created and mapped with SQL Server authentication, not Windows Authentication.
  2. Verify that the server authentication for the database engine is set to Mixed mode. To allow SQL Server and Windows authentication.
  1. In SSMS, right mouse click on the database engine.
  2. Select Properties.
  3. In the Server Properties, select the Security-section.
  4. Verify that the SQL Server and Windows Authentication mode is selected under the Server authentication.
  1. Verify the Windows Firewall is accepting communication with SQL Server.

Now try to open the dossier again in Followin´, by following the steps earlier described. You should be able select the MS SQL database containing the Followin´ dossier.

Image